BETA

11th September 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/09/17 10:51 AM] with 'Partial Outage'

Issue has been resolved at [11/09/17 10:52 AM]