BETA

9th September 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [09/09/17 01:51 PM] with 'Partial Outage'

Issue has been resolved at [09/09/17 02:02 PM]