BETA

9th September 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [09/09/17 12:50 PM] with 'Major Outage'

Issue has been resolved at [09/09/17 12:51 PM]