BETA

6th September 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [06/09/17 04:04 PM] with 'Partial Outage'

Issue has been resolved at [06/09/17 04:15 PM]