BETA

31st August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [31/08/16 12:13 AM] with 'Partial Outage'

Issue has been resolved at [31/08/16 12:17 AM]