BETA

31st August 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [31/08/17 09:10 PM] with 'Partial Outage'

Issue has been resolved at [31/08/17 09:25 PM]