Exotel Status Board
Home
Dashboard
BETA
27th November 2023
Kerala
Issue observed for 'Outgoing Calls' in Kerala Region
Identified at [27/11/23 05:20 PM] with 'Major Outage'
Issue has been resolved at [27/11/23 05:25 PM]