BETA

25th November 2023

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [25/11/23 06:07 AM] with 'Partial Outage'

Issue has been resolved at [25/11/23 07:10 AM]