BETA

28th August 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [28/08/17 04:06 PM] with 'Major Outage'

Issue has been resolved at [28/08/17 04:11 PM]