Exotel Status Board
Home
Dashboard
BETA
24th November 2023
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [24/11/23 06:17 AM] with 'Major Outage'
Issue has been resolved at [24/11/23 06:20 AM]