BETA

26th August 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [26/08/17 11:38 AM] with 'Major Outage'

Issue has been resolved at [26/08/17 11:45 AM]