BETA

22nd August 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [22/08/17 06:05 PM] with 'Partial Outage'

Issue has been resolved at [22/08/17 06:06 PM]