BETA

22nd August 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [22/08/17 01:53 PM] with 'Major Outage'

Issue has been resolved at [22/08/17 01:58 PM]