BETA

22nd August 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [22/08/17 01:07 PM] with 'Major Outage'

Issue has been resolved at [22/08/17 01:14 PM]