Exotel Status Board
Home
Dashboard
BETA
30th October 2023
Gujarat
Issue observed for 'Outgoing Calls' in Gujarat Region
Identified at [30/10/23 10:15 AM] with 'Major Outage'
Issue has been resolved at [30/10/23 12:05 PM]