BETA

28th October 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [28/10/23 12:46 AM] with 'Major Outage'

Issue has been resolved at [28/10/23 12:50 AM]