Exotel Status Board
Home
Dashboard
BETA
28th October 2023
Delhi
Issue observed for 'Outgoing Calls' in Delhi Region
Identified at [28/10/23 12:45 AM] with 'Major Outage'
Issue has been resolved at [28/10/23 01:03 AM]