BETA

19th August 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [19/08/17 08:38 AM] with 'Major Outage'

Issue has been resolved at [19/08/17 08:42 AM]