BETA

17th August 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [17/08/17 11:39 PM] with 'Partial Outage'

Issue has been resolved at [18/08/17 01:31 AM]