BETA

25th October 2023

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [25/10/23 11:12 PM] with 'Major Outage'

Issue has been resolved at [25/10/23 11:35 PM]