BETA

17th August 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [17/08/17 11:36 PM] with 'Partial Outage'

Issue has been resolved at [17/08/17 11:37 PM]