BETA

25th October 2023

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [25/10/23 08:05 PM] with 'Major Outage'

Issue has been resolved at [25/10/23 08:27 PM]