Exotel Status Board
Home
Dashboard
BETA
21st October 2023
Kerala
Issue observed for 'Outgoing Calls' in Kerala Region
Identified at [21/10/23 10:30 AM] with 'Major Outage'
Issue has been resolved at [21/10/23 10:55 AM]