BETA

16th August 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [16/08/17 06:57 PM] with 'Major Outage'

Issue has been resolved at [16/08/17 07:02 PM]