BETA

19th October 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [19/10/23 05:20 PM] with 'Major Outage'

Issue has been resolved at [19/10/23 05:25 PM]