Exotel Status Board
Home
Dashboard
BETA
13th October 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [13/10/23 06:30 AM] with 'Major Outage'
Issue has been resolved at [13/10/23 06:35 AM]