BETA

14th August 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/08/17 12:04 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/08/17 12:13 AM]