BETA

9th August 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [09/08/17 12:06 AM] with 'Major Outage'

Issue has been resolved at [09/08/17 12:07 AM]