BETA

29th August 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [29/08/16 10:12 PM] with 'Partial Outage'

Issue has been resolved at [29/08/16 10:42 PM]