Exotel Status Board
Home
Dashboard
BETA
10th October 2023
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [10/10/23 05:35 AM] with 'Major Outage'
Issue has been resolved at [10/10/23 05:40 AM]