BETA

3rd October 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [03/10/23 07:37 AM] with 'Major Outage'

Issue has been resolved at [03/10/23 07:40 AM]