BETA

7th August 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [07/08/17 01:45 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [07/08/17 06:25 AM]