BETA

19th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [19/03/19 01:00 AM] with 'Partial Outage'

Issue has been resolved at [19/03/19 01:01 AM]