BETA

29th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [29/08/16 10:09 PM] with 'Partial Outage'

Issue has been resolved at [29/08/16 10:59 PM]