BETA

2nd September 2023

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [02/09/23 02:20 AM] with 'Major Outage'

Issue has been resolved at [02/09/23 02:55 AM]