BETA

31st August 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [31/08/23 05:43 PM] with 'Partial Outage'

Issue has been resolved at [31/08/23 06:38 PM]