BETA

6th August 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [06/08/17 03:42 PM] with 'Partial Outage'

Issue has been resolved at [06/08/17 03:47 PM]