BETA

6th August 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [06/08/17 03:36 PM] with 'Major Outage'

Issue has been resolved at [06/08/17 03:51 PM]