BETA

6th August 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [06/08/17 03:33 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [07/08/17 12:29 PM]