Exotel Status Board
Home
Dashboard
BETA
17th July 2023
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [17/07/23 04:35 AM] with 'Major Outage'
Issue has been resolved at [17/07/23 04:40 AM]