Exotel Status Board
Home
Dashboard
BETA
13th June 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [13/06/23 02:45 PM] with 'Major Outage'
Issue has been resolved at [13/06/23 02:50 PM]