Exotel Status Board
Home
Dashboard
BETA
12th June 2023
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [12/06/23 02:50 PM] with 'Major Outage'
Issue has been resolved at [12/06/23 03:00 PM]