Exotel Status Board
Home
Dashboard
BETA
12th June 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [12/06/23 01:10 PM] with 'Major Outage'
Issue has been resolved at [12/06/23 01:15 PM]