Exotel Status Board
Home
Dashboard
BETA
11th June 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [11/06/23 05:55 AM] with 'Major Outage'
Issue has been resolved at [11/06/23 06:00 AM]