Exotel Status Board
Home
Dashboard
BETA
10th June 2023
Indonesia
Issue observed for 'Incoming Calls' in Indonesia Country
Identified at [10/06/23 07:40 PM] with 'Major Outage'
Issue has been resolved at [10/06/23 08:00 PM]