Exotel Status Board
Home
Dashboard
BETA
10th June 2023
Indonesia
Issue observed for 'Outgoing Calls' in Indonesia
Identified at [10/06/23 06:00 PM] with 'Major Outage'
Issue has been resolved at [10/06/23 07:35 PM]