BETA

9th June 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [09/06/23 04:10 PM] with 'Major Outage'

Issue has been resolved at [09/06/23 04:25 PM]