Exotel Status Board
Home
Dashboard
BETA
8th June 2023
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [08/06/23 04:35 AM] with 'Major Outage'
Issue has been resolved at [08/06/23 04:40 AM]