BETA

6th August 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [06/08/17 12:54 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [06/08/17 02:29 PM]