Exotel Status Board
Home
Dashboard
BETA
31st May 2023
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [31/05/23 03:05 PM] with 'Major Outage'
Issue has been resolved at [31/05/23 04:37 PM]